"Duplicate key" errors when attempting to update Content

Incident Report for Contentful

Resolved

This incident has been resolved.
Posted Apr 23, 2025 - 13:31 UTC

Monitoring

We have deployed a fix for this issue and are monitoring the results. Customer should no longer be experiencing these types of "duplicate key" errors.
Posted Apr 23, 2025 - 13:25 UTC

Identified

We have identified an issue which was introduced in the past week where a small subset of customer requests are receiving the following error:
"duplicate key value violates unique constraint "draft_entries_fts_space_id_entry_id_locale_unique": duplicate key value violates unique constraint "draft_entries_fts_space_id_entry_id_locale_unique".
We have narrowed down the root cause and are working on a fix for the issue.
Posted Apr 23, 2025 - 10:45 UTC