Increased latency and timeouts for Management, Preview and Delivery APIs

Incident Report for Contentful

Resolved

The increased error rate and latency was confirmed to be subsided.
Posted Feb 27, 2025 - 19:09 UTC

Monitoring

We observed recovery for the past 30 minutes. We are monitoring the situation and investigating further the cause to prevent it to resurface.
Posted Feb 27, 2025 - 18:52 UTC

Investigating

We identified an increase of latency and timeouts on the Management and Preview Content APIs. We are investigating the root cause.
Posted Feb 27, 2025 - 18:33 UTC
This incident affected: Content Management API.