Delayed cache invalidation after content publish

Incident Report for Contentful

Resolved

This incident has been resolved.
Posted May 29, 2024 - 16:33 UTC

Monitoring

We scaled the cache invalidation infrastructure for the affected customers and saw the back pressure of the queues come back down to normal levels. We continue to monitor the situation, so the issue doesn't reappear.
Posted May 29, 2024 - 14:14 UTC

Investigating

We're investigating an issue where a small minority of our customers might see delayed cache invalidation on our content delivery network after publish that might result in some of their end users seeing stale content for longer than expected.
Posted May 29, 2024 - 14:07 UTC
This incident affected: Content Delivery API and GraphQL Content API.